Comfort  Automation/ Security System Forums Home

 Moderated by: slychiu Topic closed
AuthorPost
ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

The new beta Android Phone app version 1.08 is now available for downoad from http://www.cytech.biz/android_app.html

The Tablet version will be available later (hopefully not too much later)

This fixes many bugs and has operational improvements


It requires  the new UCM firmware 7.002 see http://www.comfortforums.com/forum81/3189.html and Comfort firmware 7.005 (beta)


The update of the Control Menu Status has been improved as it is much faster with the new firmware

A major change is that when the app is not terminated, it will not log out or lose the connection with the IP address. The UCM/ETH02 will time out when idle based on the idle time settings in DS Manager



Last edited on Sunday Dec 9th, 2012 02:34 am by ident

ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

Wexfordman posted


hi ident, well the app is now loading the config okay, but I have to say, no difference at all in the time to load values and displat states etc, in fact, it looks worse to me, as sometimes it takes so long, it is not reading anything at all and I just shut it down. When i compare it to the iphone app, the iphone is near instant compared to the android app. pretty much unusable android app at the moment, except for basic security functions.
Please upgrade Comfort to ULT 7.005 (Beta) as well. This requires both UCM and Comfort firmware to be upgraded to work with the new android app

The status update for the control menu should be much faster than in the iPhone app using the old firmware. With the old firmware the iphone app would request the status individually which would take some time if the control menu has many items while the new firmware will report the changes immediately

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5524
Status: 
Offline

  back to top

You should see the status update fast on the Tablet app version 1.85 also, with the new UCM and Comfort firmware
Import the cclx file into both apps

wexfordman
UCM Pi Users
 

Joined: Monday Jan 1st, 2007
Location: Cork, Ireland
Posts: 546
Status: 
Offline

  back to top

Hi,
I already had both ucm eth01 and comfort firmware upgraded earlier in the week using the new version of comfigurator.

Anydroid app still very slow on my HTC one x.

Even when I turn on a light, the light goes on but app does not show New status even after 60secs.

Scs values are intermittent in reporting back temps, and sometimes. Don't report back at all

Last edited on Sunday Dec 9th, 2012 08:32 am by wexfordman

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5524
Status: 
Offline

  back to top

can you compare directly to the iPhone app with the same file?

How slow do you mjean? Does the status appear after seconds, or minutes ?

What is the android OS version?

Can you try deleting the app and reinstalling?

wexfordman
UCM Pi Users
 

Joined: Monday Jan 1st, 2007
Location: Cork, Ireland
Posts: 546
Status: 
Offline

  back to top

Just un installed and reinstalled the app and configuration file. No change in response times, and not updating status of lights at all. Iphone app working fine.

I can see pir sensors activate and clear down but the control menu is either not updating or incredibly slow.

I can send you on my conversion file and settings to demonstrate for yourselves if you want, let me know the email address.

My android version is 4.04 and by slow I mean either minutes or not at all.

Last edited on Sunday Dec 9th, 2012 08:45 am by wexfordman

Ingo
UCM Pi Users


Joined: Sunday Jan 21st, 2007
Location: South Africa
Posts: 562
Status: 
Offline

  back to top

I am also not seeing my Control Menu updating... The light goes On but shows it still in Off state in Control Menu.

Running Android 2.3 on HTC Desire.

Ingo

wexfordman
UCM Pi Users
 

Joined: Monday Jan 1st, 2007
Location: Cork, Ireland
Posts: 546
Status: 
Offline

  back to top

Just to update, I double checked my firmware, and noticed comfort was at 6.028, and eth was at 7.02!!

I was sure I had updated to latest fw, but as 7.05 was beta, it had not picked up and told me i was latest fw.

anyway, i upraded comfort to the beta fw, and checked everything again, but no change, still having same problems.

Sorry for confusion!

I also, created a new conversion file from and added it to my app, but also no change. Its odd, I get some device reporting back but others just blank, for example 1 scs reported back temp settings, the others remained blank!

Last edited on Sunday Dec 9th, 2012 06:32 pm by wexfordman

Ingo
UCM Pi Users


Joined: Sunday Jan 21st, 2007
Location: South Africa
Posts: 562
Status: 
Offline

  back to top

Some feedback from my side. I have two UCM's and connecting the one using Android and the other with Comfigurator I can see the bus messages.

On initial Android login, and pressing the Control menu, there are no CM command messages to query the COntrol Menu status. This morning however when I press either the On of Off menu options does update. This is not consistent though as wexfordman has also noticed.

When executing my Response manually I can see th CM command reply come in but the Android App doesn't respond to it, the status doesn't update.

Ingo
ULT7.005/UCM7.002

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5524
Status: 
Offline

  back to top

we are tracking down this problem and should have a fix soon

wexfordman
UCM Pi Users
 

Joined: Monday Jan 1st, 2007
Location: Cork, Ireland
Posts: 546
Status: 
Offline

  back to top

Hi, any update?

ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

we are still working on it, no update yet

Ingo
UCM Pi Users


Joined: Sunday Jan 21st, 2007
Location: South Africa
Posts: 562
Status: 
Offline

  back to top

I also ran the Android App through my Simulator and saw that the CM commands do go out to the network. From this side it just looks like the cm replies are not being actioned.

Ingo

tman
Comfort Distributors
 

Joined: Wednesday Sep 22nd, 2010
Location: United Kingdom
Posts: 22
Status: 
Offline

  back to top

Is there any way of disabling the button press "clack" sound?

waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

Hi can someone explain how I get the comfigurator file loaded into this app. I have tried a samsung galaxy s2 & s3, followed the instructions and got it emailed to me then opened it and it asked me to select the profile to use.

I get confirmation confirming it was selected and then nothing. It does not ask me to log in or even open the app. If I then go and open the app and input my login it connects to the system but I cannot see any zone information or home control menus.

I have tried uninstalling and reinstalling and updating to latest firmware as above but nothing works.

I managed to get it onto the S2 after many attempts using the old app but it only did it once and I could not replicate it.

Thanks

waynebr
Member


Joined: Friday May 1st, 2009
Location: United Kingdom
Posts: 89
Status: 
Offline

  back to top

Don't know what I have done but it just started working :)I haven't finished programming so will try again once I have made changes.

ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

I get confirmation confirming it was selected and then nothing. It does not ask me to log in or even open the app. If I then go and open the app and input my login it connects to the system but I cannot see any zone information or home control menus.

We have  noticed this
When you import a file into an exiting configuration, the zones and control menu cannot be seen.
What you need to do is go into the config and  EDIT the config, then OK and log in
You will see the zones and control menu


ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

Is there any way of disabling the button press "clack" sound?
Maybe we can find a better sound. disable means you may not know if the button is pressed, sound gives a good feedback

Ingo
UCM Pi Users


Joined: Sunday Jan 21st, 2007
Location: South Africa
Posts: 562
Status: 
Offline

  back to top

How about an option of Sound, Vibration and Sound or Vibration only? All selectable in the configuration menu.

slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5524
Status: 
Offline

  back to top

We certainly would like to, but it has not been a smooth experience getting things done for this android app as you can see by the time it has taken

It is not satisfactory at all

wexfordman
UCM Pi Users
 

Joined: Monday Jan 1st, 2007
Location: Cork, Ireland
Posts: 546
Status: 
Offline

  back to top

Hi Slychiu.

Sorry to hassle, but any news on a fix yet ?

ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

No fix yet

But the version 1.04 should  not have the status update problem with the new firmware UCM and Comfort firmware if you would like "downgrade" to this, attached

Attachment: CytechAPhone104.zip (Downloaded 2 times)

cleaner
Member


Joined: Monday Oct 3rd, 2011
Location: China
Posts: 23
Status: 
Offline

  back to top

1.08 beta was 4 months ago, yet problems not been fixed!!

We never  expect such bad response from cytechs

wexfordman
UCM Pi Users
 

Joined: Monday Jan 1st, 2007
Location: Cork, Ireland
Posts: 546
Status: 
Offline

  back to top

Downgraded to 1.04, still very slow response time to get initial status of devices though.

Any time line on a fix?

ident
Administrator


Joined: Wednesday Aug 9th, 2006
Location: Singapore
Posts: 3493
Status: 
Offline

  back to top

It is difficult to put a time to a fix
Once we have it fixed we will post it


UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems