Comfort Home Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

Any attempt to write resets Comfort
 Moderated by: admin
 New Topic   Reply   Printer Friendly 
 Rate Topic 
AuthorPost
 Posted: Sunday Nov 3rd, 2019 12:26 pm
   PM  Quote  Reply 
1st Post
palmlodge
Member
 

Joined: Thursday Dec 14th, 2006
Location: United Kingdom
Posts: 489
Status: 
Offline

  back to top

After many many years, I finally got round to doing the UCM cable upgrade method and performed a system wide upgrade of Comfort from v6.0x to the latest and all the UCMs. That appears to have been successful.
I then noticed today some lights were on and some groups not updating from CBUS, although I can still control CBUS OK where I have the CBUS switch activate a Comfort output, so not totally disconnected.

Anyway, I thought I'd just go and re-write the entire current Comfort configuration back to Comfort and have a clean config. The problem I have is that any attempt to write the config to Comfort just resets Comfort, the write bar stuck at 0%.
I'm using Comfigurator 3.12.15 via one UCM, and I've also tried Comfigurator 3.6.8 on a different UCM. Attempting on both exhibits the same issue. I also yanked the power to the board and the battery, and tried again, same issue.

So, right now I have a 'sick' system that isn't totally response, and no apparent way to re-write the config back. Each time I make a config change I create a new file, and have copies going all the way back to 2004. My latest config was created a week ago and worked perfectly well before the firmware upgrade.
Any ideas on how I can debug this, or reset Comfort to be able to write the config back?
Thanks!

Last edited on Sunday Nov 3rd, 2019 12:27 pm by palmlodge



 Posted: Sunday Nov 3rd, 2019 12:48 pm
   PM  Quote  Reply 
2nd Post
palmlodge
Member
 

Joined: Thursday Dec 14th, 2006
Location: United Kingdom
Posts: 489
Status: 
Offline

  back to top

I have a feeling that an input from 17 onwards isn't being read neither, they'll be inputs from a daughterboard?
Update, even input 1 which is an exit route is not working, so I cannot arm the alarm at all!

Last edited on Sunday Nov 3rd, 2019 01:17 pm by palmlodge



 Posted: Sunday Nov 3rd, 2019 01:03 pm
   PM  Quote  Reply 
3rd Post
palmlodge
Member
 

Joined: Thursday Dec 14th, 2006
Location: United Kingdom
Posts: 489
Status: 
Offline

  back to top

I've now reflashed the Comfort firmware with the same revision, no change, still resets on any attempt to perform a full config write.



 Posted: Sunday Nov 3rd, 2019 01:54 pm
   PM  Quote  Reply 
4th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4686
Status: 
Offline

  back to top

Can you do a read from comfort and save the file then send to support @cytech  BizCan you do a scan for modules  



 Posted: Sunday Nov 3rd, 2019 02:00 pm
   PM  Quote  Reply 
5th Post
palmlodge
Member
 

Joined: Thursday Dec 14th, 2006
Location: United Kingdom
Posts: 489
Status: 
Offline

  back to top

Yes, I can scan for modules, that seems to work as it did before. Comfort to CBUS is still working, but Comfort input detection doesn't fully appear to work correctly across the board.

I'll send the config file now. This config file was working before the firmware update.

I also just tried loading Comfigurator with NO config, performed a selective READ on just the zones/inputs, then attempted a selective WRITE on just zone/inputs. Counter stopped at 2% and Comfort reset itself, so this doesn't appear to be my config that's at fault?

Last edited on Sunday Nov 3rd, 2019 05:04 pm by palmlodge



 Posted: Sunday Nov 3rd, 2019 05:06 pm
   PM  Quote  Reply 
6th Post
palmlodge
Member
 

Joined: Thursday Dec 14th, 2006
Location: United Kingdom
Posts: 489
Status: 
Offline

  back to top

Some updates. I believe inputs 1 - 16 are working OK, inputs 17 upwards are not. 17 is a final exit door, and 18 is an InstantDayNightAway door.

So something has gone wrong with the firmware update that now means the expansion module is not being detected as well as the inability to write a config.



 Posted: Monday Nov 4th, 2019 03:58 pm
   PM  Quote  Reply 
7th Post
Home
Comfort Distributors
 

Joined: Wednesday Jul 12th, 2006
Location: United Kingdom
Posts: 730
Status: 
Offline

  back to top

Do you have a SEP  or LEM03 ?
Check the upgrade to 7.X or tick box for LEM.
Have you tried changing the U4 chip ! There is usually a spar in the older UCM slots



 Posted: Monday Nov 4th, 2019 07:47 pm
   PM  Quote  Reply 
8th Post
palmlodge
Member
 

Joined: Thursday Dec 14th, 2006
Location: United Kingdom
Posts: 489
Status: 
Offline

  back to top

I've managed to get things working using this specific sequence

-Downgrade Comfort to 7.032
-Power cycle Comfort
-Re-write the exact same config back to Comfort

This works.


I then try every single version of the firmware posted from 7.032 to 7.160, all 18 of them.

The last version to work is 7.099, and all versions after that fails to work. I have an early C2 board which has the upgrade firmware on a small daughterboard if that makes a difference.

So, I think I've been quite thorough, and that ask of Cytech is, what changed in 7.099 and can we put that fix into a new version so I can upgrade to the latest.

Last edited on Monday Nov 4th, 2019 08:21 pm by palmlodge



 Posted: Tuesday Nov 5th, 2019 02:35 am
   PM  Quote  Reply 
9th Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 4686
Status: 
Offline

  back to top

Thanks that is very thorough, we will check the changes after 7.099However there are many systems which were upgraded past 7.100 so it is a mystery  at the moment. Ppwerhaps it has to do with the cclx file



 Posted: Tuesday Nov 5th, 2019 08:09 am
   PM  Quote  Reply 
10th Post
palmlodge
Member
 

Joined: Thursday Dec 14th, 2006
Location: United Kingdom
Posts: 489
Status: 
Offline

  back to top

I don't think it's the config file. On the latest firmware, if I load Comfigurator with no config at all, do a read of the config from Comfort, and then attempt to write that back, it fails and resets Comfort.



 Current time is 02:49 pm
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems