Comfort  Automation/ Security System Forums Home
Home Search search Menu menu Not logged in - Login | Register

EMS Firmware 7.173 to 7.200
 Moderated by: slychiu
 New Topic   Reply   Printer Friendly 
 Rating:  Rating
AuthorPost
 Posted: Thursday Jun 18th, 2020 08:20 am
   PM  Quote  Reply 
1st Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5488
Status: 
Offline

  back to top

EMS7.173
Known Bugs
  • Dial Out to Phones and SMS Does not work
  • Event log has sensor values =0 so event log gets filled up quickly
Bugs Fixed
  • fix bug from EMS 7.159 – if counter setpoint is out of limits, setpoint is changed to within limit but the counter value is not updated correctly and causes endless loop

Changes
  • RS485 command 89H supports 3rd byte as fractional sensor value = 0 instead of FF is no 3rd byte. But UCM/Zwave PP parameter is supported for Zwave only. Sensor 3rd byte applies to EMS only
  • For EMS sensor event log, if module which reported sensor has Communications Failure, set sensor value to 255 so KP04A display does not remain unchannged as last value reported, and causes alarm
  • Implemented Sensor calibration with Fractional value 1/16 for EMS to  work with UCM 7.121 and built in eth03
  • sensors adjustment for scale fix bug for division
  • EMS sensor event log, fixed BUG that sensors 9 onwards are not recorded correctly. Changed so that any sensor with counter assigned is recorded in event log every hour
  • Sensor Register calibration in eeproM is 1/16 units to use calibration value with 1/16 unit calibration value from EEPROM

Last edited on Saturday Feb 26th, 2022 07:12 am by slychiu



 Posted: Saturday Feb 26th, 2022 07:11 am
   PM  Quote  Reply 
2nd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5488
Status: 
Offline

  back to top

EMS 7.195(K)
Bugs Fixed
  • Fixed BUG - dial out to Phone and CMS  did not work
New Features/Changes
  • Sensor Values do not go into event log is the sensor value is 0. This prevents the event log from filling up with unused sensor values



 Posted: Saturday Jun 3rd, 2023 03:25 am
   PM  Quote  Reply 
3rd Post
slychiu
Administrator


Joined: Saturday Apr 29th, 2006
Location: Singapore
Posts: 5488
Status: 
Offline

  back to top

EMS 7.200
Bugs Fixed
  •  Fixed BUG wifi detection was wrong  if no module plugged in  on 10 way connector. Controller may keep resetting if there is no plug in. As a result Initialisation may take up to 3 seconds after power on if ETH03 is plugged in.
  • LED03 RED  ON when wifi detected. LED3 red led will go off  if wifi submodule is not detected
  • Fixed BUG for  LGX01, UCM/Logic, KNX/Logic - if eeprom file system is incorrect, Controller does not poll ucms so it was not possible to write to Comfort
  • Fixed BUG in comfort protocol messages CTNNvv was seen as NNvv without CT
New Features and Changes
  • d? query will reply d?00 if Motion Timer is  disabled ( NOT NA) -0 works for ETH03 plug in not UCM which needs firmware upgrade
  • Power failure alarm increased delay from 10 secs to 60 seconds due to some systems having power failuyre alarms suspectshort drop in power caused the problem. sent to Robert astrol to test
  • Improved Saving Flags in eeprom for EMS and LGX



 Current time is 05:15 pm
Top




UltraBB 1.172 Copyright © 2007-2014 Data 1 Systems